Yes, I know. Its been a while. We made it home from our trip. The trip was great – wonderful cool weather, good food, good company, and fabulous new places.

What we came home to wasn’t quite so fabulous. Apparently it was hot while we were gone. Triple digit hot. So since we were not around to give plants the extra water they needed, we lost stuff. The cucumbers are toast (yup that’s what they looked like) as were some of the squash plants. Apparently one of the connectors came undone, so out of about 8 squash plants only 2-3 sort of survived. One is doing okay, but I’m not sure the other two will survive. And the corn is entirely dead. Oh well.  Did not lose a single tomato plant, but they were a bit worse for the wear. And some of the strawberry plants didn’t make it – not enough water.

Now that we’re back I am watering some of the plants to see how well they’ll survive. Also we’ve cooled down to the low 90’s (that’s Texas for you, low 90’s is cool) and with the extra water some plants are coming back. For instance, with the extra water some of the squash plants are putting out new squashes. Some of the tomatoes are starting to ripen. Even the strawberry plants are perking up with extra water.

But since its been a while and we’re coming into our second growing season, I think it may be time to feed. I’ll try to do that this week or next weekend. Oh, and didn’t lose a single pepper plant. But the red on the vine peppers are edible, hot but not as hot as they were green.

Leave a Reply

Your email address will not be published. Required fields are marked *